For all issues regarding the Forums use, please, refer to the Forum Rules.

Our Solutions

Need professional assistance?
Consider our:

Support Offerings

 

Need to speed up your development?
Have a look at our:

Samples & Tools

 

Need some functionality extending standard OCCT capabilities?
Check out our:

Adv. Components

Related pages

CAD Assitant on Mavericks

Robert Kay's picture
Forums: 

Hi,

CAD Assitant crashes when launching on Mavericks (10.9) and therefore cannot be used.

How to proceed for?

Best regards

Kirill Gavrilov's picture

If you see a Crash Report window - can you share the information from it?
Which Apple device (model) do you use?
Have you tried installing a previous release of CAD Assistant from Downloads page?

Robert Kay's picture

Hello,

No crash report window appears. Only a standard apple window indicating only that the software left unexpectedly.

My Apple device is a Macmini.

I did not try to install a previous release since I did not find the link for that.

Best regards

B. Kay

Kirill Gavrilov's picture

I have to apologize for misinformation about minimal OS requirements - CAD Assistant 1.0 has switched from Qt 5.6 to Qt 5.9, and I've just checked that this Qt version supports OS X 10.10+ (Yosemite) but not 10.9 (Mavericks), so that we have to update Download page and .plist to reflect these changes (with proper plist OS X would say clearly that newer version of system is required instead of a silent crash due to missing libraries/symbols).

Due to Apple system updating policy, it is quite difficult testing application on older versions - in fact we just don't have any workstation with Mavericks to test. But we will try improving our testing environment to handle this issue in future.

You still can use CAD Assistant 0.9 or older releases on your system if you cannot update it for some reason - check " Previous releases" on Download page:
https://www.opencascade.com/content/cad-assistant