For all issues regarding the Forums use, please, refer to the Forum Rules.

Our Solutions

Need professional assistance?
Consider our:

Support Offerings

 

Need to speed up your development?
Have a look at our:

Samples & Tools

 

Need some functionality extending standard OCCT capabilities?
Check out our:

Adv. Components

Related pages

[Bug report] Regression in 6.5.0 - ZBufferTrihedron loses user-defined color

Roman Lygin's picture
Forums: 

User-defined color of the axes names in V3d_View::TriedronDisplay() is ignored and some default light-gray color is used.

Reproducer in DRAW:

pload ALL
vinit
vzbufftrihedron
# internally calls V3dView->TriedronDisplay( Aspect_TOTP_LEFT_LOWER, Quantity_NOC_WHITE, 0.1, V3d_ZBUFFER );

In 6.3.x the axes names are correctly displayed in white while in 6.5.0 there is always a default color.
I could not quickly debug the issue - the initial color is correctly propagated into OpenGL structures but seems to get lost somewhere later.

Not a fundamental flaw but any regression is bad anyway :-|.

Hope this helps.
Roman

Forum supervisor's picture

Hi Roman,
I would like to inform you that the posted problem is checked and reproduced.
The corresponding issue with ID = OCC22483 has been registered.
Later you can know if the issue is resolved by checking references to the specified ID in OCCT Release Notes. The analysis of the issue will take some time depending on our technical capability and availability of resources.

Regards

Roman Lygin's picture

Thanks for a prompt action!