For all issues regarding the Forums use, please, refer to the Forum Rules.

Our Solutions

Need professional assistance?
Consider our:

Support Offerings

 

Need to speed up your development?
Have a look at our:

Samples & Tools

 

Need some functionality extending standard OCCT capabilities?
Check out our:

Adv. Components

Related pages

Accentuated characters in visualisation

Anonymous's picture
Forums: 

Hi, all
I try to display a text with accentuated characters in the 3D viewer, and I only obtain square in the place of the accentuated characters.
I search the forum but found nothing interesting.

Best regards.
Jerome.

Mikael Aronsson's picture

Hi !

The internal string management in OCC is unicode so ther should not be any problem, first of all, on what platform are you running OCC ?, Windows95,98 and Me does not have full unicode support so it's possible that this cause some problems, the only other thing I can think of is that there is a problem somewhere in converting between the codepage you are using and unicode or reverse.

If you enter a string, then I guess this is converted to unicode somewhere on the way as I guess you are not entering a unicode string, that's the first place, the second is when it is displayed, I once again guess that it is converted back to ansi....

Sorry, that's all I can think of.

Mikael

jerome's picture

Thanks for this quick answer.
I'm working on W2000, it is unicode also.
I've certainly made a mistake in my code. I'll check it.

Regards.
Jerome.

Mikael Aronsson's picture

Hi again !

It is of course also possible that the font used to display the text does not support the character you try to display, didn't think of that first.

Mikael

Contact us

Attention: DO NOT use this form for all kind of request for the removal of your personal data. Please follow this link for such cases.