Our Solutions

Need professional assistance?
Consider our:

Support Offerings


Need to speed up your development?
Have a look at our:

Samples & Tools


Need some functionality extending standard OCCT capabilities?
Check out our:

Adv. Components

Opencascade is retruning wrong result for Union of the attached Solids.

Sharad Verma's picture

Hi All,

These two solids are correct -> Checked using BRepCheck_Analyzer.
The Shells are correct -> Checked using BRepCheck_Analyzer.
The faces are correct -> Checked using BRepCheck_Analyzer.
The edges are correct -> Checked using BRepCheck_Analyzer.

Even I fixed all the entities with ShapeFix packages, but nothing works for the solids.

But still, Union of the two solids is Incorrect. Please check the attached zipped file containing Solid1.brep, Solid2.brep and Union.brep.

Help Guys.

Sharad Verma

PG's picture

failing in 6.5.3 test harness too.
faulty shapes in result.
On Shape faulty_1 :
Shape faulty_2 on shape faulty_1 :

Faulty shapes in variables faulty_1 to faulty_2

Sharad Verma's picture

Thanks for the reply PG. But i could not really understand what you want to say? Can you pleas elaborate further. A small code snippet will be very useful. or tell me which class to use, to test the same.

Thanks again for your response.

PG's picture

basically tested ur brep files for boolean operation in OCC test harness application
to check the output.

Sharad Verma's picture

Yes PG,

The result is incorrect. I just want to know, whether there is any problem with the input solids, or this is a bug in OpenCascade?

Can you please help me with this issue?

Forum supervisor's picture

Dear Sharad,
If you have doubts in the result you may register the issue in Mantis Bugtracker,
which is available now via the Collaborative portal - http://dev.opencascade.org/index.php?q=home/get_involved.
The issue will be analyzed and you will get a qualified answer.

Sharad Verma's picture

Hi, PG.

Did you find out, why OCC is returning wrong result with the attached solids.

Sharad Verma

PG's picture

It seems to be an OCC bug as it is reprodicible in Test harness. For public user's , only bug tracker is there. good luck - pg